How not to welcome a new customer


Way back in October of 2008 when I launched My Technology Fetish I intended to use WordPress as the blogging platform while using the Mac Mini I owned as the server. It didn’t take long to realize I didn’t know what I was doing (or how to install mySQL navigating a Linux command line in OS X) and I bailed out by setting up with Blogger.

Blogger is a fine blogging platform. Its free and effortless to setup. Yet its’ not very customize-able, has no developer community building cool gizmos, gadgets or templates and I get bored with bad designs rather quickly. If you’ve paid attention over the years this site has gone through a lot changes. At some point in the future I will migrate this site from Blogger to WordPress but in the meantime I’ll start with Chris Kenst.com and later merge in Search N Recovery.

I decided to find a web hosting company that specializes in WordPress hosting and at the recommendation of a friend chose iPage. (Matt you owe me lunch once you get that Affiliate credit!) iPage offers unlimited domain hosting, unlimited disk space, unlimited bandwidth, etc. and the service was promotion-ally cheap. What could go wrong you say?

After signing up I chose to pay for 3 years of service (the promotion pricing was tied to pre-payment) using PayPal. Upon paying I get an error saying “something failed” while trying to process my PayPal payment. I love helpful error messages. So I try again. This time the payment process appears to be successful but I don’t get a welcome or thank you or confirmation page, instead iPage throws a 500 error. Welcome new paying customer! (Is the sarcasm coming through?) I had to log into PayPal to verify the money was deducted before I knew my sign up was complete.

A few minutes later I got an email with log-in information and an order confirmation. The amount listed on the order was incorrect (the PayPal invoice was correct) because it showed the rate of the plan I selected but not the extra feature which had a small additional cost. Great… Well at least my account was now ready, right? Wrong. When I tried using the log-in information from the email to access my account I got log-in errors. Seeing no directions in the email I turned to iPage’s online chat where the agent instructed me to wait 10 minutes. Once 10 minutes passed I was in.

Simple right?

I’m a software tester and I get it – things break. Any company should be concerned when a string of problems all related to new customer acquisition are this severe. It’s as if iPage was telling me they really didn’t want my business so much they tried getting rid of me at several points along the way. I kept thinking this was a great example of how NOT to welcome a new web hosting customer.